You are not logged in

LoginRegister

FinePix S2980

FinePix S2980Members and their FinePix S2980View now

Log in

FinePix X100

Touch Your World - Enter the competition for a chance to win a FinePix Z800EXR

Camera reviews

Own a FinePix camera? Why not tell people what you think about it by writing a review?

Photo Features

Get involved!

"turn off the camera and turn on again" FinePix S2980

"turn off the camera and turn on again"

I got this error after connecting it with my television. Could it be repaired? (I'm still under warranty) And it was my life.... :'( wanna die without it!

 

0 people like this.

Reply to comment


Date Thu, 07/02/2013 - 16:03
Comment

You do not say what has happened other than the error message. Your camera should be able to show video via a mini HDMI cable between the camera and the TV set, it would be normal procedure to select one of the AV channels on your TV set, connect your camera to a mini HDMI cable that was plugged into your HDMI socket on your TV and then turn the camera on. If you are saying that after you have connected to your TV you are getting an error message when you try to use it normally, then you may have a problem. I would suggest that you just removed the batteries from the camera and leave it for 20 minutes before replacing them again. You will have to reset the date and time again, but this may just clear any error that has occurred while connecting to your TV.

Reply to comment


Date Thu, 07/02/2013 - 20:08
Comment

In the Spanish forum we have an exclusive topic for this message. Very usual in the J and S cameras.

Cameras that a yesterday were working well, and today refuse to turn on.  Showing the mensage ""turn off the camera and turn on again" time after time. 

If the camera is under guarantee, do not think more and contact with the technical service. It can be repaired. 

Although we have discovered the home-made solution that works in most instances. 

The mensage ""turn off the camera and turn on again" often appears when the zoom's gear gets stuck. Yes, without hits, without falls and for no reason at all. Disconcerting, but already are it proven in a lot of cameras of different models. 

The solution is tapping lightly on the objective lens upon the  turn on, soft but steady. 

It is also been worth tapping next to the flash or even pulling smoothly the objective lens during the turn on. 

You can read somebody else's experience that had the same problem and that they solved it. Evidently, written in spanish. 

http://www.myfinepix.ie/forum/69/537341 

http://www.myfinepix.ie/forum/3/303990 

But I repeat, if this camera is under guarantee, contact with the technical service for more assurance.

Reply to comment

Date Sat, 09/02/2013 - 09:07
Comment

@teztec,

I was using the A/V connector to connect with the TV, and not mHDMI. I connected camera and then turned it on. Still then, the camera was in a working condition and could take pictures. From then it began to show the error, and even cant take pictures! 

whenever after the incident, turning it on shows the error, the lens wont come out.still i can wander around the settings menu and tried it again by manually resetting the cam. 

@maturanga

 

tried it! Still not working. 

 

 

 

 

 

Reply to comment


Date Sat, 09/02/2013 - 22:29
Comment

I would doubt that it has anything to do with connecting it to the TV other than it may have flattened the batteries and that is why the lens will not power out. Have you tried replacing a completely new or recharged set of batteries in the camera? if not then try that first, otherwise it looks like it may need a repair.

Reply to comment

Date Thu, 14/02/2013 - 17:00
Comment

unfortunately, i have tried that. that 4 batteries then replaced by a new set of batteries and also tried with the same batteries with recharging to max...

Guess i'll need a service from fuji.

i've also contacted with the fuji, they directed me a service center near me.

Reply to comment

Date Thu, 14/02/2013 - 17:00
Comment

unfortunately, i have tried that. that 4 batteries then replaced by a new set of batteries and also tried with the same batteries with recharging to max...

Guess i'll need a service from fuji.

i've also contacted with the fuji, they directed me a service center near me.